summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..7e71ff2
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,24 @@
+SET(SOURCES
+ bitmap.cpp
+ level.cpp
+ main.cpp
+ train.cpp
+ window.cpp
+)
+
+add_executable(
+ Nonortho
+ ${SOURCES}
+)
+
+target_include_directories(
+ Nonortho
+ PUBLIC
+ ${PROJECT_SOURCE_DIR}/include
+)
+
+target_link_libraries(
+ Nonortho
+ PRIVATE
+ SDL2::SDL2
+)